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1.Introduction 
 

This lab is a tutorial on Cadence Virtuoso, which is the simulation tool we will use for the rest of the 

semester. The official program name is Virtuoso, but the common name among users is just Cadence. We 

will use the name Cadence in this class. 

 

2. Cadence Tutorial 
 
 

2.1. Cadence Setup and Launch 
 

➢ Follow the steps as shared in Class’ Teams Group. 

➢ Make sure your system is connected to IISc network, either directly or via IISc VPN. 

➢ Open Terminal & type ./icl and hit Enter. 

 

 

 

 

 

 

 

 

 
1 
This document is a modified version of https://inst.eecs.berkeley.edu/~ee105/fa17/labs/Lab0.pdf

http://nitss.iisc.ac.in/?p=256
https://inst.eecs.berkeley.edu/~ee105/fa17/labs/Lab0.pdf
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2.2.  Cadence overview 
 

After opening Cadence, you'll see the main window: 

 

Go to Tools->Library Manager, it should open the following window: 

 

 
 

 

The hierarchy in Cadence is: 

Library (left side) -> Cell (middle) -> View (right). 

A library contains multiple cells, and each cell contains multiple views. 

The libraries that we will use in this tutorial are: 

• analogLib - the basic analog components (resistors, capacitors, voltage and current sources, etc) 

• umc65ll - the actual components that we will use in the lab (transistors, diodes, opamps, ...). We 

won't use them in this tutorial. 

• lab0 - your designs 

The views that we will use for each cell are: 

• schematic - the actual circuit, the components and interconnections 

• spectre - the simulation setup 

• symbol - the appearance of the cell in another schematic view
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Creating a new Library  

To create a new library, go to the library manager and click File → New → Library. A new window 

will pop up. Go into “mylibraries” folder & t\ype “lab0” in the name field and press OK. 
 

 

 
 

 

At this point, Cadence will prompt you for something called a Technology File. The technology file is 

collection of information and libraries that define the layers and devices available for a given process 

technology. 
 

 

 
 

 

For this class, we will not use any technology file. Therefore, go ahead and choose ‘Do not need 

process information’. 
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Creating a new schematic 

To create a new schematic design: 

Click on the lab0 library in the Library Manager. 

File -> New -> Cell View 

A new window pops up, but it may be at the background: 

This is a general tip in Cadence - if you expect a window to open and it's not there, check the taskbar! 

 

 

 

 

 

 

 

 

 

 

 

 

We will give it a name "tutorial", the type should be "schematic". Note that you can make cells in any 

available library by choosing proper one from ‘Library’ (if you have permissions to edit). 

Click OK. The following window will open:
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Click "Always" to avoid getting this message later. The schematic window will open: 

 
This is the main window where we'll draw our circuit. Generally, we won't use the menus, but keyboard 

shortcuts. 

 

Adding components 

To add an element, click "i". The following window will appear: 

 

You can type the library, cell and view names, or click Browse: 

Select "analogLib" library, "res" cell and "symbol" view. Another window will open: 
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Here you specify the parameters of the component. A resistor has a single parameter (resistance), change it 

to 20kΩ. 

In Cadence you don't have to write the units (Ohms, volts, etc.). For the resistance, type 20k and hit 

Tab. The Ohms will be automatically completed. The useful prefixes in Cadence are single letters: 

p - pico, n - nano, u - micro, m - milli, k - kilo, M - mega, G – giga. 

 

Click on the schematic window to place the resistor. 

The useful components in the analogLib library are: 

 

res Resistor 

cap Capacitor 

gnd Ground 

vdc/idc DC voltage/current source 

vsin/isin Sinusoidal voltage/current source 

vpulse/ipulse Square-wave voltage/current source 

iprobe Current meter 
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Now add another resistor of 10kΩ. Click "Rotate" to make it horizontal and place it on the schematic: 

Your schematic should look like this: 
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Adding wires and labels 

To connect the resistors with a wire, click "w". Click on the first terminal to connect, and then on the 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To create a wire label, click "l" (lowercase L). Type out and click on the wire. Click Esc. Now 

you have the following schematic: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Labels can be used to connect nodes. If you want to connect two nodes in your circuit, you can give 

them the same label, without connecting them with a wire. It is usually useful for large circuits, to 

reduce the number of wires. Labels are also useful for output expressions, as we will see later.

Other useful shortcuts 

•  Components - click on the desired component, then click: 

o c - copy component 

o m - move component (preserves the wire connections) 

o Shift+M - move component (without the wire connections) 

o q - edit component properties (same window as the add component window) 

•  f - fits the circuit to fit the screen 

•  mouse scroll - zoom in and out 
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•  z - selects area to zoom 

•   Shift+X - check and save. Check that all nodes are connected properly. If you have errors, you have 

to fix them to simulate the circuit. You can run simulations if you have warnings. Pay attention to the 

warnings, usually they indicate a problem in your circuit, like unconnected nodes. 

 

2.3. DC simulation - Resistive divider 
 

Add a DC voltage source and grounds to create the resistive divider circuit shown in Figure 1. 

10kΩ 
Vout 

 

3V                        20kΩ 
 
 

Figure 1: Resistor circuit to build 

 

You should get the following schematic: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click Shift+X to check and save your schematic. 

To open the simulation window, click Launch -> ADE L. You will see the following window: 

 

 

 

 

 

 

Click "Always" to avoid getting this message later. 
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The ADE window will open: 

 
 

The Analysis box - specifying the simulation type 

In the Analysis box: right click -> Edit. 

Here we select the different simulation types for our schematic.  

The useful simulations in our class are: 

• dc - DC simulation. Only DC sources are used, and the results are DC voltages and DC currents. 

This is in general a non-linear analysis (unless we only have linear components, like in our 

case). 

• ac - AC simulation. This is a linear phasor analysis of the circuit. The simulation result is a 

phasor (magnitude and phase) of the voltages and the currents in our circuit. We can use it to 

calculate the transfer function from the input to the desired output. Here we define the frequency 

range to perform the simulation. 

• tran - transient simulation. This is a non-linear time-domain simulation. The simulation results 

are time-domain waveform of the voltages and the currents in our circuit. 
 

 

In this part of the tutorial we will perform a DC simulation. Select dc, and check "Save DC operating 

point": 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Click OK.
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The Outputs box - specifying the simulation outputs 

After performing the simulation, we should specify the results that we are interested in. 

In the Outputs box: right click -> Edit.  

In the Name section type: out_dc. 

In the Expression section, type: VDC("/out"): 

 

 
 
 
 
 
 
 
 
 

 

 

Click OK. 

We created an output expression named "out_dc" for the DC voltage at the node "out". 

 

A very useful tool in Cadence for the output expressions syntax is the calculator. In the main ADE 

window:  Tools -> Calculator. At the bottom, you have a list of the various functions that can be 

performed on the simulation results. If you are not sure about the command syntax, the Calculator is 

a very useful place to start. 

The syntax for the output expressions is: 
 

VDC/IDC DC voltage/current (dc analysis) 

VF/IF AC voltage/current (ac analysis) 

VT/IT Transient voltage/current (tran analysis) 

For voltage outputs, the syntax is VDC ("/node_name"). For current output, the syntax is IDC 

("/component_name/terminal name"). 

In our circuit to see the terminal name of the 20k resistor connected to "out", click on it (the red 

square) and press q. 

 

You will see the following window: 
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So, the component name is R0 and the terminal name is PLUS. For the output DC current through this 

node add the following output expression: IDC("/R0/PLUS"): 

 
Another option is to click on idc in the Calculator, and then click on the resistor terminal. 

To save your simulation setup: Session -> Save State. At the top change to "Cellview": 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click OK. It will a view named "spectre_state1" in the "tutorial" cell.  
 

 

Click the "play" button to perform the simulation. You should see the simulated DC voltage and current 

at the Value column. Add the screenshot of the ADE window with the simulated result to your lab 

worksheet.
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2.4. AC and transient simulation - RC low-pass 
We will build the RC low-pass circuit shown in Figure 2. 

10kΩ 
 

 
Vs 

 

 
Vout 

 
10nF

 
 

Figure 2: RC circuit to build 

 

Note that the output node should have a different name than "out", otherwise it will be shorted to the 

resistive divider output. The source should be "vsin": 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

AC magnitude is used for AC simulation, Amplitude and Frequency are used in transient simulation. 

Here we used variables Vtran and freq_tran rather than fixed values.  

For the capacitance value use a variable named C. 

You should have the following schematic: 
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In the ADE window, we can add the variables used in the schematic by right-click at the Design 

Variables area, and selecting "Copy from Cellview": 

 
 

 

Set C=10nF, transient amplitude of 0.5V (1Vptp) and frequency of 1KHz: 

 
 

 

AC simulation 

Add an AC (ac in ADE) simulation. We will sweep the frequency in a logarithmic scale between 1Hz 

and 1MHz: 

 

 

 

 

 

 

 

 

 

 

 

 

 



P a g e  | 15 

 

 

Anshaj Shrivastava | IISc, Bangalore 

To add the transfer function output:  

 
 

A window with the plots will open: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The transfer function is a complex number. Cadence is always plotting the magnitude by default. 

We will switch to bode-style (log-log) plot, by right-click on the y axis and selecting "Log Scale": 
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lue to the output expressions we can use value() function. The value() function is 

returns the function value for a specific x-axis (frequency in this case) value. The 

We can add a marker by pressing "m" and double-clicking the marker to select the frequency or 

the desired y value (or moving the marker with the mouse). For 1KHz: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 

To add a marker value to the output expressions we can use value() function. The value() function is 

an x-axis marker. It returns the function value for a specific x-axis (frequency in this case) value. 

The syntax: 

 

So far,  we plotted the magnitude of the transfer function. Add another output expression for 

the phase of the transfer function, using the phase() function. 

 

Parametric sweep 

Now we will sweep the capacitance value and look at the simulation result for each value. In the AD 

window Tools -> Parametric Analysis. Fill the following sections: Variable: C, From: 5n, To: 20n, Step 

Mode: Linear Steps, Step Size: 5n: 

 

 

 

 

 

To run the parametric sweep, click on the "play" button in the parametric sweep window. Attach the 

following parametric sweep plots to your lab worksheet: 

• The transfer function magnitude vs frequency (in log-log scale) 

• The transfer function magnitude value at 1KHz 
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• The transfer function phase vs frequency 

• The transfer function phase value at 1KHz. 

 

Transient simulation: 

Add a transient (tran in ADE) simulation:  

 

 

 

 

 

 

 

 

 

 

 

The stop time is 3msec (3 time periods), and the accuracy is "conservative" (usually slow for large 

circuits, but OK for small circuits like ours). 

Add an output expression for the out_RC node, and attach the plot to your lab worksheet. 

 

--- End of The Document --- 
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